среда, 24 июня 2009 г.

Обновляем Ruby on rails на Leopard 10.5.6

в терминале проверяем что надо обновить из гемов
gem outdate
обновляем сам гем
sudo gem update --system

ставим Xcode tools
и обновляем все гемы
sudo gem update


если нужно ставим mysql и соответственно ставим гем
sudo env ARCHFLAG="=arch i386" gem install mysql --\--with-mysql-include=/usr/local/mysql/include \--with-mysql-lib=/usr/local/mysql/lib
для sqlite3
sudo env ARCHFLAGS="-arch i386" gem install sqlite3-ruby

Комментариев нет: